Arquivar por categoria Mikrotik

Acessando Mikrotik Remotamente

# Dynamic DNS Update / Simple Edition
# Written by Sam Norris, ChangeIP.com
# Copyright ChangeIP.com 2009-2010
# For support send mail to Support@ChangeIP.com
#
# 2009-06-22 RouterOS 3.25 Tested
# 2009-10-05 RouterOS 4.01rc1 Tested
#
# OVERVIEW: %
# This script will update a ChangeIP.com dynamic dns hostname
# with an ip address located directly on an interface.
# %
# NOTES: %
# IF THIS SCRIPT DOES NOT PRODUCE ANY OUTPUT PLEASE COPY AND PASTE IT
# AGAIN. THERE PROBABLY IS A LINE BREAK IN THE WRONG PLACE! Once you
# have created this script and tested that it works by running it
# manually you can schedule it to run every few minutes.
# %
# CONFIGURATION FIELD DEFINITIONS:
# ddnsuser: Enter your ChangeIP.com user id.
# ddnspass: Enter your ChangeIP.com password.
# ddnshost: Enter the hostname (www.example.com) to update.
# ddnsinterface: Enter an interface name – case sensative.
# %
# %
# %
# %
# % % %
# % % %
# % % %
# %
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# EDIT YOUR DETAILS / CONFIGURATION HERE
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
:global ddnsuser “seu usuario”
:global ddnspass “sua senha”
:global ddnshost “link_do_site”
:global ddnsinterface “ether1″
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# END OF USER DEFINED CONFIGURATION
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

:global ddnssystem (“mt-” . [/system package get [/system package find name=system] version] )
:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
:global ddnslastip

:if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info “DDNS: No interface named $ddnsinterface, please check configuration.” }

:if ([ :typeof $ddnslastip ] = “nothing” ) do={ :global ddnslastip 0.0.0.0/0 }

:if ([ :typeof $ddnsip ] = “nothing” ) do={

:log info (“DDNS: No ip address present on ” . $ddnsinterface . “, please check.”)

} else={

:if ($ddnsip != $ddnslastip) do={

:log info “DDNS: Sending UPDATE!”
:log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
:global ddnslastip $ddnsip

} else={

:log info “DDNS: No changes necessary.”

}

}

# END OF SCRIPT
# INSIRA EM…. SYSTEM -> SCHEDULE , COLOQUE O TEMPO DE ATUALIZAÇÃO CONFORME SUA NECESSIDADE.. Eu coloquei 30 minutos
# Abraços KUROLE.com

Nenhum comentário.

Criar log de acesso dos sites visitados

Você pode implementar isto daqui no seu mikrotik acabei de fazer e deu certinho!

Para windows:

Baixe o Mikrotik syslog daemon (ou outro syslog que desejar);
No winbox va em System, logging, Rules +, Topics=web-proxy; action, remote

Agora na Aba actions, + , nome Remoto , Nome remoto, tipo= remote, e remote address o endereço da maquina rodando o mikrotik syslog daemon. Abra o syslog daemon e vc vai ver os URL passado…

Donwload do Mikrotik Daemon

http://www.mikrotik.com/download/MT_Syslog.exe

Nenhum comentário.